Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Erste Schritte im Editor...

Moderator: US-Team

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon Jörg » 19.05.2017, 17:31

ok -naja windows 10 kommt mir nichtmehr auf meinem Rechner...

Hat jemand Ideen/Vorschläge für eine preiswerte USB-soundkarte bei der man dann auch im Partymodus spielen kann?
Ultrastar scheint einen Line-In eingang (Stereo) nicht splitten zu können. :/
Benutzeravatar
Jörg
Beginner
 
Beiträge: 5
Registriert: 14.05.2017, 20:01
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon Jörg » 22.05.2017, 20:40

Wie müsste man vorgehen um Ultrastar in Retropie einzubinden?
Benutzeravatar
Jörg
Beginner
 
Beiträge: 5
Registriert: 14.05.2017, 20:01
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon C4_87 » 23.05.2017, 18:04

Benutzeravatar
C4_87
SuperStar
 
Beiträge: 344
Registriert: 11.12.2007, 11:42
Wohnort: Dresden
Geschlecht: Männlein

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon mk00 » 11.06.2017, 10:19

Ich hab soweit alles nach Anleitung hinbekommen.
Wenn ich jedoch UltraStar Deluxe starte... kommt kurz der Lade Bildschirm und dann springt er mir auf den Debian Anmeldebildschirm.
Was mach ich Falsch bzw wie kann man das beheben ?
Benutzeravatar
mk00
Beginner
 
Beiträge: 2
Registriert: 09.01.2015, 21:07
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon smokers » 17.06.2017, 13:48

Hallöchen Leute,


erstmal danke für das Tutorial. Leider bin ich beim letzten Schritt - beim Compilieren von USDX - noch nicht fertig geworden.
Der Prozess terminiert mit dem Fehler:
Code: Alles auswählen
/usr/local/USDX/src/base/UMusic.pas(253,61) Error: Procedure directive "STATIC" has conflicts with other directives
/usr/local/USDX/src/base/UMusic.pas(253,61) Error: Fields cannot appear after a method or property definition, start a new visibility section first
/usr/local/USDX/src/base/UMusic.pas(253,67) Fatal: Syntax error, ":" expected but ";" found
Fatal: Compilation aborted
Error: /usr/local/bin/ppcarm returned an error exitcode
Makefile:223: recipe for target '../game/ultrastardx' failed
make: *** [../game/ultrastardx] Error 1


Hier mein Setup:

[list=]Raspbian GNU/Linux 8.0 (jessie)
Free Pascal Compiler version 3.1.1 [2017/06/17] for arm
ffmpeg version 1.2.12 Copyright (c) 2000-2015 the FFmpeg developers[/list]

Ist es, weil ich zum Compilieren FPC 3.1.1 nutze und nicht wie im Tutorial beschrieben 3.0?

Ich hatte bereits diverse Konstellationen durch,...
ffmpeg 3.3.2 (die aktuellste) --> hier ging der configure prozess nicht weiter weil USDX nur 3.2 unterstützt.
ffmpeg 3.2.5 --> hier ging die configuration von USDX auch nicht, gleiche fehlermeldung wie bei ffmpeg 3.3.2 (ffmpeg version nicht unterstützt)

Ich habs dann erstmal weiter hinbekommen mit der hier auf Seite 1 genannten 1.2.12 Version.

Jetzt komme ich wie gesagt mit dem "make -j4" nicht mehr weiter, da die genannten Compilierungs-Fehler auftreten.
Jemand eine Idee wie ich weiter kommen kann?


//PS: Habe es mit dem aktuellen Arbeitsstand aus dem GIT versucht sowie mit dem 1.3.5er Release. Gleiches Ergebnis.

Danke für die Hilfe.
Benutzeravatar
smokers
Beginner
 
Beiträge: 4
Registriert: 13.06.2017, 10:13
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon basisbit » 17.06.2017, 23:31

Bitte ffmpeg 2.8.x oder 3.0.x oder 3.1.0 verwenden
Benutzeravatar
basisbit
Star
 
Beiträge: 140
Registriert: 13.08.2015, 21:48
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon smokers » 19.06.2017, 15:39

basisbit hat geschrieben:Bitte ffmpeg 2.8.x oder 3.0.x oder 3.1.0 verwenden

Vielen Dank für die Info, werde es heute Nachmittag sofort ausprobieren.


Aber mit dem Compilierungsproblem hat das doch sicher nichts zu tun, oder?


//EDIT:
also die ffmpeg version habe ich angepasst, aber ein lauffähiges FPC bekomme ich nicht hin. (bis auf das, was ich nach dieser anleitung hier gebaut habe: https://bigdanzblog.wordpress.com/2015/ ... st-lazarusfree-pascal-for-raspberry-pi/ --> dieses bringt aber die fehlermeldung von oben hervor beim bauen von USDX)
Benutzeravatar
smokers
Beginner
 
Beiträge: 4
Registriert: 13.06.2017, 10:13
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon MM07 » 21.06.2017, 15:43

Hey, kann mir jemand sagen wenn ich alles erfolgreich installiert habe und USDX dann startet, kommt man in den Ladebildschirm von USDX. Kurz danach wird der Schirm schwarz und man landet im Anmeldebildschirm vom Pi.
Jemand eine Idee wie man das zum laufen bringt?

@update
USDX läuft wenn ich in Advanced Option -> GL Driver -> Legacy erlaube mit nur 4FPS, sobald ich den GL (Full KMS) Open GL desktop driver with full KMS aktiviere passiert der oben genante Fehler.
Benutzeravatar
MM07
Beginner
 
Beiträge: 7
Registriert: 02.11.2010, 19:28
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon Nidhoegger » 22.06.2017, 08:22

Hallo,

ich hatte in letzter zeit mich weiter mit der Materie auseinanderzusetzen und habe recht Gute Nachrichten. Ich habe beim ffmpeg ein paar recht nette compileroptionen gefunden, die das Videoplayback für h264 codierte Videos MASSIV beschleunigt! Ich werde hoffentlich in den nächsten Wochen mein Tutorial updaten können.

Gruß

Nidhoegger
Benutzeravatar
Nidhoegger
Amateur
 
Beiträge: 17
Registriert: 11.03.2016, 20:55
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon basisbit » 22.06.2017, 08:30

@MM07 vermutlich liefert dein Netzteil zu wenig Spannung/Strom
Benutzeravatar
basisbit
Star
 
Beiträge: 140
Registriert: 13.08.2015, 21:48
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon smokers » 22.06.2017, 10:14

Auch ich habs inzwischen alles hinbekommen ;-D

Mit
- ffmpeg 3.1
- fpc 3.0.0 und
- USDX latest from GIT (2017-06-21)
-------


Aus mir unerklärlichen Gründen ist das Spiel aber dennoch nicht spielbar :-/
wenn ich OpenGL deaktiviere geht das Spiel zwar, aber vieeeeeel zu langsam. Nicht spielbar.

Wenn ich OpenGL in Fake KMS setze, ist der Pixel Desktop in Ordnung und funktioniert, aber das Spiel startet nicht.


Wenn ich OpenGL Full KMS aktiviere, wird mein Fernseher falsch erkannt (der Rand vom Bild wird massiv abgeschnitten) sodass überall locker 100px fehlen. Leider lässt sich das auch nicht reparieren da Overscan mit OpenGL nicht implementiert wurde. Außerdem startet das Spiel nicht mehr (es kommen nur die drei Standard-Meldungen " LibGL....MESA Could not load device information " oder so, und dann passiert nichts mehr.
Und noch besser: Das Raspberry lässt sich nicht mehr neu starten. Beim Shutdown bleibt es irgendwo hängen und ich muss hart den Strom trennen damit ich es wieder gebootet bekomme.

Leider echt ernüchternd. Wenn jemand nen Image hätte was geht, wäre ich sehr daran interessiert - nur um zu wissen ob ich irgendwas verbockt habe, oder einfach nur mein Hardware Setup mist ist, oder woran es liegt. :(
Benutzeravatar
smokers
Beginner
 
Beiträge: 4
Registriert: 13.06.2017, 10:13
Geschlecht: Bin mir nicht sicher

Re: Ultrastar 1.3.0 auf dem Raspberry Pi - Eine Anleitung

Beitragvon MM07 » 22.06.2017, 16:03

basisbit hat geschrieben:@MM07 vermutlich liefert dein Netzteil zu wenig Spannung/Strom


Danke für den Tipp, ich nutze ein Rydges EU 5V 3A Netzteil und der Pi 3 zeigt mir nicht an da er zu wenig Spannung hat.
Was benötige ich den für eins damit es stabil läuft? Gerne auch Amazon Links ;)

Danke und Gruß
Benutzeravatar
MM07
Beginner
 
Beiträge: 7
Registriert: 02.11.2010, 19:28
Geschlecht: Bin mir nicht sicher

Vorherige

Zurück zu Anleitungen

Wer ist online?

Mitglieder in diesem Forum: 0 Mitglieder und 1 Gast

cron